אתר זה עושה שימוש בעוגיות על מנת להבטיח לך את חוויית הגלישה הטובה ביותר.
jQuery לא תתמוך יותר באינטרנט אקספלורר 6/7/8

jQuery לא תתמוך יותר באינטרנט אקספלורר 6/7/8

צוות הפיתוח של פלטפורמת הקוד הפתוח jQuery הודיע כי החל מגרסה 2.0 לא תסופק תמיכה לדפדפניה הישנים של מיקרוסופט

09.07.2012, 13:31 | רפאל קאהאן

פלטפורמת הסקריפטים jQuery לא תתמוך יותר בגרסאות 6, 7 ו-8 של אינטרנט אקספלורר החל מגרסה 2.0, שתשוחרר לקראת סוף 2013. הגרסה האחרונה שתתמוך באקספלורר תהיה jQuery 1.9. כך נמסר בבלוג המפתחים.

"אם אתם זקוקים לתמיכה בגרסאות הישנות יותר אינטרנט אקספלורר, אל תתבלבלו, גרסה 1.9 היא זו שאתם צריכים." כך צוין בבלוג. גרסה 1.9 תשוחרר בתחילת 2013 ותהיה האחרונה לכלול תמיכה מובנית בגרסאות 6,7 ו-8.

ה-API ב-2.0 יתמכו באותה צורה כמו ב-1.9 רק עם חיסכון במקום ובגודל ותוך כדי שיפור בביצועים של המערכת. הסיבה העיקרית שציינו המפתחים להחלטה היא שתמיכה בגרסאות הללו מכבידה באופן מיותר על בניית האתרים ומייצרת יותר בעיות מאשר היא פותרת.

הסרת התמיכה מדפדפניה הפופולרים של מיקרוסופט גרמה להרמת גבות מצד רבים, בעיקר כאשר מדובר בפלטפורמת פיתוח שמתכנתים רבים משתמשים בה.

שיתוף בטוויטר שיתוף בוואטסאפ שיתוף בפייסבוק שיתוף במייל

תגיות