אתר זה עושה שימוש בעוגיות על מנת להבטיח לך את חוויית הגלישה הטובה ביותר.
מומחים: איתרנו פרצת אבטחה חמורה אף יותר מ-Heartbleed צילום: shutterstock

מומחים: איתרנו פרצת אבטחה חמורה אף יותר מ-Heartbleed

הפרצה החדשה, המכונה Shellshock, היא ב-Bash - תשתית קוד שעליה נסמכים לא מעט שרתים ארגוניים

25.09.2014, 20:06 | הראל עילם
חוקרי אבטחה מחברת Red Hat התריעו אמש (ד') כי הצליחו לאתר פרצת אבטחה חמורה במיוחד שיכולה להשפיע על לא מעט מערכות ארגוניות. לפי החוקרים, הפרצה יכולה להיות גרועה אף יותר בהשלכות שלה מ-Heartbleed.

קראו עוד בכלכליסט

באפריל האחרון היה האינטרנט כמרקחה כתוצאה מ-Heartbleed  באג שהתגלה במערכת האבטחה וההצפנה OpenSSL, ששימשה אז קרוב ל-70% מכל האתרים באינטרנט. הפרצה מאפשרת בפועל להאקרים לעקוף את מערכת ההצפנה שקיימת באתרים מאובטחים ולגנוב מידע רגיש מהשרתים. נכון לרגע זה, ישנם עדיין אלפי אתרים שלא תיקנו את הפרצה.

 , צילום: גלעד קוולרצ צילום: גלעד קוולרצ'יק, shutterstock  , צילום: גלעד קוולרצ

הפרצה החדשה, המכונה Shellshock, היא ב-Bash - תשתית קוד שעליה נסמכים לא מעט שרתי יוניקס ולינוקס. יוניקס היא עדיין אחת המערכות הפופולריות ביותר בתחום השרתים והרשתות הארגוניות. הפרצה גם משפיעה על מערכות הפעלה פופולריות המבוססות על Bash ויוניקס, כגון OS X של מחשבי מק ורוב מערכות ההפעלה עם קרנל לינוקס. Bash גם הותאמה לווינדוס ואנדרואיד. הפירצה מאפשרת להאקרים להחדיר את הקוד שלהם ולהשתלט לחלוטין על המערכת מיד עם האתחול שלה, כמעט ללא יכולת מצד מפעילים להגן עליה מלבד התקנת טלאי החוסם את הפירצה.

חמור מכך, הפירצה קיימת ב-Bash מאז שנות השמונים, ולפי בדיקות של מומחי תוכנה מספר האקרים כבר התחילו להשתמש בה. היא מאפשרת להאקרים לחדור בצורה עמוקה יותר, ובקלות רבה יותר למערכות, מאשר אפילו Heartbleed. מחלקת החירום של הסוכנות להגנה על המולדת בארה"ב שחררה התרעה בנושא.

אנשי חברת האבטחה Errta פרסמו מוקדם יותר הבוקר שכבר הבחינו בהאקרים שהחלו בחיפושים של מערכות פגיעות לפרצה, ובחיפוש קצר הם בעצמם מצאו אלפי מערכות כאלה. היקף השימוש והפופולריות של Bash גורמת לחוקרי אבטחה להביע חשש שהפרצה לעולם לא תיעלם לחלוטין. דיוויד גרהאם, חוקר בחברה, אמר כי כל כך הרבה תוכנות ומערכות ההפעלה מבוססות על Bash שהוא אינו חושב שאי פעם יהיה ניתן לקטלג את כולן. לפי מספר הערכות, ייתכן שקרוב לחצי מיליארד מחשבים כיום יכולים להפגע ברמה זו או אחרת מ-ShellShock - פי אלף מכמות השרתים שיכלו ליהפגע מ-HeartBleed.

טד בירדסלי, מחברת האבטחה Rapid7, אמר כי הפרצה מדורגת בדרגת החומרה הגבוהה ביותר, ומדורגת "קלה" ברמת התחכום הנדרשת על מנת לבצע אותה. "בעזרת הפרצה, האקרים יכולים להשתלט על מערכות הפעלה, לגשת למידע, ולשנות כל קובץ במערכת. כל משתמש עם מערכת מבוססת Bash צריך להתקין את טלאי האבטחה באופן מיידי".

שיתוף בטוויטר שיתוף בוואטסאפ שיתוף בפייסבוק שיתוף במייל

תגיות